关于Serve 2008操作系统的兼容性问题.

分类
Qampp手册
更新时间
2017-12-02 22:49:29

本文章内容影响Qampp, Qwins两大工具.



经过测试, server 2008 / server 2008 R2 并不能支持VC++ 2017

其实包括以下几个名字. 可以参考:

Windows Server 2008 R2 Standard, Enterprise, Datacenter, and Web (x64) - DVD (Chinese-Simplified)

Windows Server 2008 R2 HPC Edition (x64) - DVD (Chinese-Simplified) 

Windows Server 2008 Datacenter, Enterprise and Standard (x64) - DVD

Windows Server 2008 Datacenter, Enterprise and Standard (x86) - DVD

Windows Server 2008 Datacenter, Enterprise and Standard without Hyper-V


以上这些没有sp1, sp2字样的均不能支持vc2017


----------------------------------------------------------------------------------------------------------------------------

VC14(2017)支持的系统有以下几种:

win7 SP1, Vista SP2, 8 / 8.1, 10, Server 2008 SP2 / R2 SP1, Server 2012 / R2, Server 2016.


其中, server 2008 sp2 ,只有sp2, 没有发行过sp1.

另外, server 2008 R2 sp1, 只有sp1, 没有发行过sp2.


所以简单理解就是2008系统一定要带sp字样的才可以兼容vc2017.


-----------------------------------------------------------------------------------------------------


带sp字样的server 2008 R2完美运行qampp.


END




Qampp 相关下载信息

Qampp APACE/PHP一键全系列环境包 : 64位, 32位,
Qampp Qampp 兼容版(winXP, win2003等) XP兼容版

数据下载由网络决定

腾讯云 / 腾讯AI / 腾讯开源 / 南沙新区 / 信用
分享工作室[粤ICP备16004795号-2] Date:2020-07-06 23:51:32(UTC) RunTime:0.012