Qampp降级php5.6版本时需要注意事项.

分类
Qampp手册
更新时间
2017-12-27 22:00:48


即使安装了qampp, 系统也是没有vc11(2012)运行库的.


php 7.0以上版本是可以完美兼容运行.



如果有需要降级php为5.6版本,


在启动组件时会有如图的异常提示.


错误代码类似:

21:53:10 [851]  错误 Message:The Apache service named  reported the following error:
>>> httpd.exe: Syntax error on line 289 of C:/qampp/apache/conf/httpd.conf: Cannot load C:/qampp/php/php5apache2_4.dll into server: \xd5\xd2\xb2\xbb\xb5\xbd\xd6\xb8\xb6\xa8\xb5\xc4\xc4\xa3\xbf\xe9\xa1\xa3     .;InString:["The Apache service named","","reported the following error:\r\n>>>","httpd.exe: Syntax error on line 289 of C:/qampp/apache/conf/httpd.conf: Cannot load C:/qampp/php/php5apache2_4.dll into server: \\xd5\\xd2\\xb2\\xbb\\xb5\\xbd\\xd6\\xb8\\xb6\\xa8\\xb5\\xc4\\xc4\\xa3\\xbf\\xe9\\xa1\\xa3","","","","",""](2017-12-27 21:52:54)


只要安装vc11(2012)运行库.



php 5.6.31即可以完美兼容运行了.


END;


分享工作室[粤ICP备16004795号-2] 腾讯云 / 腾讯AI / 南沙新区 / 信用 0.013